<!DOCTYPE html>
<html lang="en-US" itemscope itemtype="https://schema.org/BlogPosting">
<head>
	<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<link rel="pingback" href="https://princetonherald.com/xmlrpc.php" />

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
	
	<title>Early voting ends Friday; Election Day is Tuesday, Nov. 8 | Princeton Herald</title>
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin /><style id="et-builder-googlefonts-cached-inline">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</style><meta name='robots' content='max-image-preview:large' />
<script type="text/javascript">
			let jqueryParams=[],jQuery=function(r){return jqueryParams=[...jqueryParams,r],jQuery},$=function(r){return jqueryParams=[...jqueryParams,r],$};window.jQuery=jQuery,window.$=jQuery;let customHeadScripts=!1;jQuery.fn=jQuery.prototype={},$.fn=jQuery.prototype={},jQuery.noConflict=function(r){if(window.jQuery)return jQuery=window.jQuery,$=window.jQuery,customHeadScripts=!0,jQuery.noConflict},jQuery.ready=function(r){jqueryParams=[...jqueryParams,r]},$.ready=function(r){jqueryParams=[...jqueryParams,r]},jQuery.load=function(r){jqueryParams=[...jqueryParams,r]},$.load=function(r){jqueryParams=[...jqueryParams,r]},jQuery.fn.ready=function(r){jqueryParams=[...jqueryParams,r]},$.fn.ready=function(r){jqueryParams=[...jqueryParams,r]};</script><link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel="alternate" type="application/rss+xml" title="Princeton Herald &raquo; Feed" href="https://princetonherald.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Princeton Herald &raquo; Comments Feed" href="https://princetonherald.com/comments/feed/" />
<meta content="Divi v.4.14.2" name="generator"/><link rel='stylesheet' id='wp-block-library-css'  href='https://princetonherald.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.5' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<style id='divi-style-inline-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='divi-dynamic-css'  href='https://princetonherald.com/wp-content/et-cache/15001/et-divi-dynamic-tb-13279-tb-13286-tb-13280-15001.css?ver=1667417784' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-official-css'  href='https://use.fontawesome.com/releases/v5.15.4/css/all.css' type='text/css' media='all' integrity="sha384-DyZ88mC6Up2uqS4h/KRgHuoeGwBcD4Ng9SiP4dIRy0EXTlnuz47vAwmeGwVChigm" crossorigin="anonymous" />
<link rel='stylesheet' id='font-awesome-official-v4shim-css'  href='https://use.fontawesome.com/releases/v5.15.4/css/v4-shims.css' type='text/css' media='all' integrity="sha384-Vq76wejb3QJM4nDatBa5rUOve+9gkegsjCebvV/9fvXlGWo4HCMR4cJZjjcF6Viv" crossorigin="anonymous" />
<style id='font-awesome-official-v4shim-inline-css' type='text/css'>
@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-brands-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-brands-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-brands-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-brands-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-brands-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-brands-400.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-solid-900.eot"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-solid-900.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-solid-900.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-solid-900.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-solid-900.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-solid-900.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-regular-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-regular-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-regular-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-regular-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-regular-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-regular-400.svg#fontawesome") format("svg");
unicode-range: U+F004-F005,U+F007,U+F017,U+F022,U+F024,U+F02E,U+F03E,U+F044,U+F057-F059,U+F06E,U+F070,U+F075,U+F07B-F07C,U+F080,U+F086,U+F089,U+F094,U+F09D,U+F0A0,U+F0A4-F0A7,U+F0C5,U+F0C7-F0C8,U+F0E0,U+F0EB,U+F0F3,U+F0F8,U+F0FE,U+F111,U+F118-F11A,U+F11C,U+F133,U+F144,U+F146,U+F14A,U+F14D-F14E,U+F150-F152,U+F15B-F15C,U+F164-F165,U+F185-F186,U+F191-F192,U+F1AD,U+F1C1-F1C9,U+F1CD,U+F1D8,U+F1E3,U+F1EA,U+F1F6,U+F1F9,U+F20A,U+F247-F249,U+F24D,U+F254-F25B,U+F25D,U+F267,U+F271-F274,U+F279,U+F28B,U+F28D,U+F2B5-F2B6,U+F2B9,U+F2BB,U+F2BD,U+F2C1-F2C2,U+F2D0,U+F2D2,U+F2DC,U+F2ED,U+F328,U+F358-F35B,U+F3A5,U+F3D1,U+F410,U+F4AD;
}
</style>

<!-- Google Analytics snippet added by Site Kit -->
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-86338194-3' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["princetonherald.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-86338194-3", {"anonymize_ip":true});
gtag("config", "G-8N70BCK8MM");
</script>

<!-- End Google Analytics snippet added by Site Kit -->

<!-- OG: 3.1.7 -->
<meta property="og:image" content="https://princetonherald.com/wp-content/uploads/2019/07/election.jpg" /><meta property="og:image:secure_url" content="https://princetonherald.com/wp-content/uploads/2019/07/election.jpg" /><meta property="og:image:width" content="1065" /><meta property="og:image:height" content="710" /><meta property="og:image:alt" content="election" /><meta property="og:image:type" content="image/jpeg" /><meta property="og:description" content="Early voting will close Friday, Nov. 4 and Election Day is Tuesday, Nov. 8 for the November midterm elections and for 37 races at the county, state and federal level. On Election Day, the polls will be open from 7 a.m. until 7 p.m. At the local level, residents within Princeton ISD will vote to..." /><meta property="og:type" content="article" /><meta property="og:locale" content="en_US" /><meta property="og:site_name" content="Princeton Herald" /><meta property="og:title" content="Early voting ends Friday; Election Day is Tuesday, Nov. 8" /><meta property="og:url" content="https://princetonherald.com/2022/11/02/early-voting-ends-friday-election-day-is-tuesday-nov-8/" /><meta property="og:updated_time" content="2022-11-02T11:37:36-05:00" />
<meta property="article:published_time" content="2022-11-02T19:36:00+00:00" /><meta property="article:modified_time" content="2022-11-02T16:37:36+00:00" /><meta property="article:section" content="Latest" /><meta property="article:section" content="News" /><meta property="article:author:first_name" content="Staff" /><meta property="article:author:last_name" content="Reports" /><meta property="article:author:username" content="Staff Reports" />
<meta property="twitter:partner" content="ogwp" /><meta property="twitter:card" content="summary_large_image" /><meta property="twitter:image" content="https://princetonherald.com/wp-content/uploads/2019/07/election.jpg" /><meta property="twitter:image:alt" content="election" /><meta property="twitter:title" content="Early voting ends Friday; Election Day is Tuesday, Nov. 8" /><meta property="twitter:description" content="Early voting will close Friday, Nov. 4 and Election Day is Tuesday, Nov. 8 for the November midterm elections and for 37 races at the county, state and federal level. On Election Day, the polls..." /><meta property="twitter:url" content="https://princetonherald.com/2022/11/02/early-voting-ends-friday-election-day-is-tuesday-nov-8/" />
<meta itemprop="image" content="https://princetonherald.com/wp-content/uploads/2019/07/election.jpg" /><meta itemprop="name" content="Early voting ends Friday; Election Day is Tuesday, Nov. 8" /><meta itemprop="headline" content="Early voting ends Friday; Election Day is Tuesday, Nov. 8" /><meta itemprop="description" content="Early voting will close Friday, Nov. 4 and Election Day is Tuesday, Nov. 8 for the November midterm elections and for 37 races at the county, state and federal level. On Election Day, the polls will be open from 7 a.m. until 7 p.m. At the local level, residents within Princeton ISD will vote to..." /><meta itemprop="datePublished" content="2022-11-02" /><meta itemprop="dateModified" content="2022-11-02T16:37:36+00:00" /><meta itemprop="author" content="Staff Reports" />
<meta property="profile:first_name" content="Staff" /><meta property="profile:last_name" content="Reports" /><meta property="profile:username" content="Staff Reports" />
<!-- /OG -->

<link rel="https://api.w.org/" href="https://princetonherald.com/wp-json/" /><link rel="alternate" type="application/json" href="https://princetonherald.com/wp-json/wp/v2/posts/15001" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://princetonherald.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://princetonherald.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.5" />
<link rel="canonical" href="https://princetonherald.com/2022/11/02/early-voting-ends-friday-election-day-is-tuesday-nov-8/" />
<link rel='shortlink' href='https://princetonherald.com/?p=15001' />
<link rel="alternate" type="application/json+oembed" href="https://princetonherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fprincetonherald.com%2F2022%2F11%2F02%2Fearly-voting-ends-friday-election-day-is-tuesday-nov-8%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://princetonherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fprincetonherald.com%2F2022%2F11%2F02%2Fearly-voting-ends-friday-election-day-is-tuesday-nov-8%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.86.0" /><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0" />
<!-- Google AdSense snippet added by Site Kit -->
<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">
<!-- End Google AdSense snippet added by Site Kit -->
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #fbfbfb; }
</style>
	
<!-- Google AdSense snippet added by Site Kit -->
<script async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-9080583756114971" crossorigin="anonymous" type="text/javascript"></script>

<!-- End Google AdSense snippet added by Site Kit -->
<link rel="icon" href="https://princetonherald.com/wp-content/uploads/2021/08/cropped-favicon_princeton-herald-32x32.png" sizes="32x32" />
<link rel="icon" href="https://princetonherald.com/wp-content/uploads/2021/08/cropped-favicon_princeton-herald-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://princetonherald.com/wp-content/uploads/2021/08/cropped-favicon_princeton-herald-180x180.png" />
<meta name="msapplication-TileImage" content="https://princetonherald.com/wp-content/uploads/2021/08/cropped-favicon_princeton-herald-270x270.png" />
<style id="et-divi-customizer-global-cached-inline-styles">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</style></head>
<body class="post-template-default single single-post postid-15001 single-format-standard custom-background et-tb-has-template et-tb-has-header et-tb-has-body et-tb-has-footer et_button_no_icon et_pb_button_helper_class et_cover_background et_pb_gutter et_pb_gutters3 et_divi_theme et-db">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div id="page-container">
<div id="et-boc" class="et-boc">
			
		<header class="et-l et-l--header">
			<div class="et_builder_inner_content et_pb_gutters3">
		<div id="top" class="et_pb_section et_pb_section_0_tb_header et_pb_with_background et_section_regular" >
				
				
				
				
					<div class="et_pb_row et_pb_row_0_tb_header et_pb_equal_columns et_pb_row--with-menu">
				<div class="et_pb_column et_pb_column_1_4 et_pb_column_0_tb_header  et_pb_css_mix_blend_mode_passthrough">
				
				
				<ul class="et_pb_module et_pb_social_media_follow et_pb_social_media_follow_0_tb_header clearfix  et_pb_bg_layout_light">
				
				
				<li
            class='et_pb_social_media_follow_network_0_tb_header et_pb_social_icon et_pb_social_network_link  et-social-facebook'><a
              href='https://www.facebook.com/The-Princeton-Herald-125163066000/'
              class='icon et_pb_with_border'
              title='Follow on Facebook'
               target="_blank"><span
                class='et_pb_social_media_follow_network_name'
                aria-hidden='true'
                >Follow</span></a></li><li
            class='et_pb_social_media_follow_network_1_tb_header et_pb_social_icon et_pb_social_network_link  et-social-twitter'><a
              href='https://twitter.com/princetonherald?lang=en'
              class='icon et_pb_with_border'
              title='Follow on Twitter'
               target="_blank"><span
                class='et_pb_social_media_follow_network_name'
                aria-hidden='true'
                >Follow</span></a></li><li
            class='et_pb_social_media_follow_network_2_tb_header et_pb_social_icon et_pb_social_network_link  et-social-instagram'><a
              href='https://www.instagram.com/princetonherald/'
              class='icon et_pb_with_border'
              title='Follow on Instagram'
               target="_blank"><span
                class='et_pb_social_media_follow_network_name'
                aria-hidden='true'
                >Follow</span></a></li>
			</ul>
			</div><div class="et_pb_column et_pb_column_1_2 et_pb_column_1_tb_header  et_pb_css_mix_blend_mode_passthrough">
				
				
				<div class="et_pb_module et_pb_image et_pb_image_0_tb_header">
				
				
				<a href="https://princetonherald.com/"><span class="et_pb_image_wrap "><img loading="lazy" width="593" height="47" src="https://princetonherald.com/wp-content/uploads/2021/08/the-princeton-herald-logo.png" alt="" title="logo-wylie-news-plus-tagline" srcset="https://princetonherald.com/wp-content/uploads/2021/08/the-princeton-herald-logo.png 593w, https://princetonherald.com/wp-content/uploads/2021/08/the-princeton-herald-logo-480x38.png 480w" sizes="(min-width: 0px) and (max-width: 480px) 480px, (min-width: 481px) 593px, 100vw" class="wp-image-13372" /></span></a>
			</div>
			</div><div class="et_pb_column et_pb_column_1_4 et_pb_column_2_tb_header  et_pb_css_mix_blend_mode_passthrough et-last-child et_pb_column--with-menu">
				
				
				<div class="et_pb_module et_pb_menu et_pb_menu_0_tb_header et_pb_bg_layout_light  et_pb_text_align_right et_dropdown_animation_fade et_pb_menu--without-logo et_pb_menu--style-left_aligned">
					
					
					<div class="et_pb_menu_inner_container clearfix">
						
						<div class="et_pb_menu__wrap">
							<div class="et_pb_menu__menu">
								<nav class="et-menu-nav"><ul id="menu-masthead" class="et-menu nav"><li id="menu-item-13007" class="et_pb_menu_page_id-13007 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13007"><a href="#account"><I class="fa fa-user-circle"></I></a>
<ul class="sub-menu">
	<li id="menu-item-13008" class="et_pb_menu_page_id-13008 menu-item menu-item-type-custom menu-item-object-custom menu-item-13008"><a target="_blank" rel="noopener" href="https://publisher.etype.services/princeton-herald">Sign In</a></li>
	<li id="menu-item-13009" class="et_pb_menu_page_id-13009 menu-item menu-item-type-custom menu-item-object-custom menu-item-13009"><a target="_blank" rel="noopener" href="https://publisher.etype.services/princeton-herald">Subscribe</a></li>
	<li id="menu-item-13010" class="et_pb_menu_page_id-13010 menu-item menu-item-type-custom menu-item-object-custom menu-item-13010"><a target="_blank" rel="noopener" href="http://csmedia.mycapture.com/mycapture/index.asp">Media</a></li>
</ul>
</li>
<li id="menu-item-13011" class="et_pb_menu_page_id-13011 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13011"><a href="#about"><I class="fa fa-info-circle"></I></a>
<ul class="sub-menu">
	<li id="menu-item-13013" class="et_pb_menu_page_id-12914 menu-item menu-item-type-post_type menu-item-object-page menu-item-13013"><a href="https://princetonherald.com/about-us/">About Us</a></li>
	<li id="menu-item-13016" class="et_pb_menu_page_id-12947 menu-item menu-item-type-post_type menu-item-object-page menu-item-13016"><a href="https://princetonherald.com/locations/">News Rack Locations</a></li>
	<li id="menu-item-13018" class="et_pb_menu_page_id-12978 menu-item menu-item-type-post_type menu-item-object-page menu-item-13018"><a href="https://princetonherald.com/contact-us/">Contact Us</a></li>
</ul>
</li>
</ul></nav>
							</div>
							
							<button type="button" class="et_pb_menu__icon et_pb_menu__search-button"></button>
							<div class="et_mobile_nav_menu">
				<div class="mobile_nav closed">
					<span class="mobile_menu_bar"></span>
				</div>
			</div>
						</div>
						<div class="et_pb_menu__search-container et_pb_menu__search-container--disabled">
				<div class="et_pb_menu__search">
					<form role="search" method="get" class="et_pb_menu__search-form" action="https://princetonherald.com/">
						<input type="search" class="et_pb_menu__search-input" placeholder="Search &hellip;" name="s" title="Search for:" />
					</form>
					<button type="button" class="et_pb_menu__icon et_pb_menu__close-search-button"></button>
				</div>
			</div>
					</div>
				</div>
			</div>
				
				
			</div>
				
				
			</div><div class="et_pb_section et_pb_section_1_tb_header et_pb_with_background et_section_regular" >
				
				
				
				
					<div class="et_pb_row et_pb_row_1_tb_header et_pb_equal_columns et_pb_row--with-menu">
				<div class="et_pb_column et_pb_column_1_5 et_pb_column_3_tb_header  et_pb_css_mix_blend_mode_passthrough et_pb_column--with-menu">
				
				
				<div class="et_pb_module et_pb_menu et_pb_menu_1_tb_header pulldown et_pb_bg_layout_light  et_pb_text_align_left et_dropdown_animation_fade et_pb_menu--without-logo et_pb_menu--style-left_aligned">
					
					
					<div class="et_pb_menu_inner_container clearfix">
						
						<div class="et_pb_menu__wrap">
							<div class="et_pb_menu__menu">
								<nav class="et-menu-nav"><ul id="menu-mobile" class="et-menu nav"><li id="menu-item-13003" class="et_pb_menu_page_id-13003 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13003"><a href="#">Account</a>
<ul class="sub-menu">
	<li id="menu-item-13004" class="et_pb_menu_page_id-13004 menu-item menu-item-type-custom menu-item-object-custom menu-item-13004"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald">Log In</a></li>
	<li id="menu-item-13005" class="et_pb_menu_page_id-13005 menu-item menu-item-type-custom menu-item-object-custom menu-item-13005"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald">Sign Up</a></li>
</ul>
</li>
<li id="menu-item-13006" class="et_pb_menu_page_id-13006 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13006"><a href="#">Subscriptions</a>
<ul class="sub-menu">
	<li id="menu-item-13019" class="et_pb_menu_page_id-13019 menu-item menu-item-type-custom menu-item-object-custom menu-item-13019"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald">E-Edition</a></li>
	<li id="menu-item-13020" class="et_pb_menu_page_id-13020 menu-item menu-item-type-custom menu-item-object-custom menu-item-13020"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald">Subscribe / Renew</a></li>
	<li id="menu-item-13032" class="et_pb_menu_page_id-13032 menu-item menu-item-type-custom menu-item-object-custom menu-item-13032"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald">Buy a paper</a></li>
</ul>
</li>
<li id="menu-item-13021" class="et_pb_menu_page_id-13021 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13021"><a href="#">Sections</a>
<ul class="sub-menu">
	<li id="menu-item-13027" class="et_pb_menu_page_id-8 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-13027"><a href="https://princetonherald.com/category/latest/">Latest</a></li>
	<li id="menu-item-13028" class="et_pb_menu_page_id-3 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13028"><a href="https://princetonherald.com/category/sports/">Sports</a></li>
	<li id="menu-item-13029" class="et_pb_menu_page_id-7 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13029"><a href="https://princetonherald.com/category/education/">Education</a></li>
	<li id="menu-item-13030" class="et_pb_menu_page_id-4 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13030"><a href="https://princetonherald.com/category/life-style/">Life &amp; Style</a></li>
	<li id="menu-item-13031" class="et_pb_menu_page_id-5 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13031"><a href="https://princetonherald.com/category/opinion/">Opinion</a></li>
</ul>
</li>
<li id="menu-item-13022" class="et_pb_menu_page_id-13022 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13022"><a href="#">Advertise</a>
<ul class="sub-menu">
	<li id="menu-item-13023" class="et_pb_menu_page_id-13023 menu-item menu-item-type-custom menu-item-object-custom menu-item-13023"><a target="_blank" rel="noopener" href="https://etypeservices.com/ClassifiedUsers/CustomLogin.aspx?PID=245">Classifieds</a></li>
	<li id="menu-item-13024" class="et_pb_menu_page_id-13024 menu-item menu-item-type-custom menu-item-object-custom menu-item-13024"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald/Special-Editions">Special Editions</a></li>
	<li id="menu-item-13025" class="et_pb_menu_page_id-13025 menu-item menu-item-type-custom menu-item-object-custom menu-item-13025"><a target="_blank" rel="noopener" href="https://csmediatexas.com/princeton-media-kit/">Media Kit</a></li>
</ul>
</li>
<li id="menu-item-13026" class="et_pb_menu_page_id-13026 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13026"><a href="#">About</a>
<ul class="sub-menu">
	<li id="menu-item-13033" class="et_pb_menu_page_id-12947 menu-item menu-item-type-post_type menu-item-object-page menu-item-13033"><a href="https://princetonherald.com/locations/">About Us</a></li>
	<li id="menu-item-13034" class="et_pb_menu_page_id-12978 menu-item menu-item-type-post_type menu-item-object-page menu-item-13034"><a href="https://princetonherald.com/contact-us/">Contact Us</a></li>
</ul>
</li>
</ul></nav>
							</div>
							
							
							<div class="et_mobile_nav_menu">
				<div class="mobile_nav closed">
					<span class="mobile_menu_bar"></span>
				</div>
			</div>
						</div>
						
					</div>
				</div>
			</div><div class="et_pb_column et_pb_column_3_5 et_pb_column_4_tb_header  et_pb_css_mix_blend_mode_passthrough et_pb_column--with-menu">
				
				
				<div class="et_pb_module et_pb_menu et_pb_menu_2_tb_header et_pb_bg_layout_dark  et_pb_text_align_left et_dropdown_animation_fade et_pb_menu--without-logo et_pb_menu--style-left_aligned">
					
					
					<div class="et_pb_menu_inner_container clearfix">
						
						<div class="et_pb_menu__wrap">
							<div class="et_pb_menu__menu">
								<nav class="et-menu-nav"><ul id="menu-sections" class="et-menu nav"><li id="menu-item-12985" class="et_pb_menu_page_id-8 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12985"><a href="https://princetonherald.com/category/latest/">Latest</a></li>
<li id="menu-item-12986" class="et_pb_menu_page_id-3 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12986"><a href="https://princetonherald.com/category/sports/">Sports</a></li>
<li id="menu-item-12987" class="et_pb_menu_page_id-7 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12987"><a href="https://princetonherald.com/category/education/">Education</a></li>
<li id="menu-item-12984" class="et_pb_menu_page_id-5 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12984"><a href="https://princetonherald.com/category/opinion/">Opinion</a></li>
<li id="menu-item-12983" class="et_pb_menu_page_id-4 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12983"><a href="https://princetonherald.com/category/life-style/">Life &amp; Style</a></li>
<li id="menu-item-12988" class="et_pb_menu_page_id-21 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12988"><a href="https://princetonherald.com/category/obituaries/">Obituaries</a></li>
<li id="menu-item-12982" class="et_pb_menu_page_id-12982 menu-item menu-item-type-custom menu-item-object-custom menu-item-12982"><a target="_blank" rel="noopener" href="https://etypeservices.com/ClassifiedUsers/CustomLogin.aspx?PID=245">Classifieds</a></li>
<li id="menu-item-12989" class="et_pb_menu_page_id-22 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12989"><a href="https://princetonherald.com/category/public-notices/">Public Notices</a></li>
<li id="menu-item-12990" class="et_pb_menu_page_id-12990 menu-item menu-item-type-custom menu-item-object-custom menu-item-12990"><a target="_blank" rel="noopener" href="http://csmedia.mycapture.com/mycapture/index.asp">Photos</a></li>
</ul></nav>
							</div>
							
							
							<div class="et_mobile_nav_menu">
				<div class="mobile_nav closed">
					<span class="mobile_menu_bar"></span>
				</div>
			</div>
						</div>
						
					</div>
				</div>
			</div><div class="et_pb_column et_pb_column_1_5 et_pb_column_5_tb_header  et_pb_css_mix_blend_mode_passthrough et-last-child">
				
				
				<div class="et_pb_button_module_wrapper et_pb_button_0_tb_header_wrapper et_pb_button_alignment_right et_pb_module ">
				<a class="et_pb_button et_pb_button_0_tb_header et_pb_bg_layout_light" href="https://publisher.etype.services/Princeton-Herald">Subscribe</a>
			</div>
			</div>
				
				
			</div>
				
				
			</div><div class="et_pb_with_border et_pb_section et_pb_section_2_tb_header et_pb_fullwidth_section et_section_regular" >
				
				
				
				
					<div class="et_pb_module et_pb_fullwidth_menu et_pb_fullwidth_menu_0_tb_header et_pb_bg_layout_light  et_pb_text_align_right et_dropdown_animation_fade et_pb_fullwidth_menu--with-logo et_pb_fullwidth_menu--style-left_aligned">
					
					
					<div class="et_pb_row clearfix">
						<div class="et_pb_menu__logo-wrap">
			  <div class="et_pb_menu__logo">
				<a href="https://princetonherald.com/" ><img loading="lazy" width="593" height="47" src="https://princetonherald.com/wp-content/uploads/2021/08/the-princeton-herald-logo.png" alt="" srcset="https://princetonherald.com/wp-content/uploads/2021/08/the-princeton-herald-logo.png 593w, https://princetonherald.com/wp-content/uploads/2021/08/the-princeton-herald-logo-480x38.png 480w" sizes="(min-width: 0px) and (max-width: 480px) 480px, (min-width: 481px) 593px, 100vw" class="wp-image-13372" /></a>
			  </div>
			</div>
						<div class="et_pb_menu__wrap">
							<div class="et_pb_menu__menu">
								<nav class="et-menu-nav fullwidth-menu-nav"><ul id="menu-mobile-1" class="et-menu fullwidth-menu nav"><li class="et_pb_menu_page_id-13003 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13003"><a href="#">Account</a>
<ul class="sub-menu">
	<li class="et_pb_menu_page_id-13004 menu-item menu-item-type-custom menu-item-object-custom menu-item-13004"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald">Log In</a></li>
	<li class="et_pb_menu_page_id-13005 menu-item menu-item-type-custom menu-item-object-custom menu-item-13005"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald">Sign Up</a></li>
</ul>
</li>
<li class="et_pb_menu_page_id-13006 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13006"><a href="#">Subscriptions</a>
<ul class="sub-menu">
	<li class="et_pb_menu_page_id-13019 menu-item menu-item-type-custom menu-item-object-custom menu-item-13019"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald">E-Edition</a></li>
	<li class="et_pb_menu_page_id-13020 menu-item menu-item-type-custom menu-item-object-custom menu-item-13020"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald">Subscribe / Renew</a></li>
	<li class="et_pb_menu_page_id-13032 menu-item menu-item-type-custom menu-item-object-custom menu-item-13032"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald">Buy a paper</a></li>
</ul>
</li>
<li class="et_pb_menu_page_id-13021 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13021"><a href="#">Sections</a>
<ul class="sub-menu">
	<li class="et_pb_menu_page_id-8 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-13027"><a href="https://princetonherald.com/category/latest/">Latest</a></li>
	<li class="et_pb_menu_page_id-3 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13028"><a href="https://princetonherald.com/category/sports/">Sports</a></li>
	<li class="et_pb_menu_page_id-7 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13029"><a href="https://princetonherald.com/category/education/">Education</a></li>
	<li class="et_pb_menu_page_id-4 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13030"><a href="https://princetonherald.com/category/life-style/">Life &amp; Style</a></li>
	<li class="et_pb_menu_page_id-5 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13031"><a href="https://princetonherald.com/category/opinion/">Opinion</a></li>
</ul>
</li>
<li class="et_pb_menu_page_id-13022 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13022"><a href="#">Advertise</a>
<ul class="sub-menu">
	<li class="et_pb_menu_page_id-13023 menu-item menu-item-type-custom menu-item-object-custom menu-item-13023"><a target="_blank" rel="noopener" href="https://etypeservices.com/ClassifiedUsers/CustomLogin.aspx?PID=245">Classifieds</a></li>
	<li class="et_pb_menu_page_id-13024 menu-item menu-item-type-custom menu-item-object-custom menu-item-13024"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald/Special-Editions">Special Editions</a></li>
	<li class="et_pb_menu_page_id-13025 menu-item menu-item-type-custom menu-item-object-custom menu-item-13025"><a target="_blank" rel="noopener" href="https://csmediatexas.com/princeton-media-kit/">Media Kit</a></li>
</ul>
</li>
<li class="et_pb_menu_page_id-13026 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-13026"><a href="#">About</a>
<ul class="sub-menu">
	<li class="et_pb_menu_page_id-12947 menu-item menu-item-type-post_type menu-item-object-page menu-item-13033"><a href="https://princetonherald.com/locations/">About Us</a></li>
	<li class="et_pb_menu_page_id-12978 menu-item menu-item-type-post_type menu-item-object-page menu-item-13034"><a href="https://princetonherald.com/contact-us/">Contact Us</a></li>
</ul>
</li>
</ul></nav>
							</div>
							
							
							<div class="et_mobile_nav_menu">
				<div class="mobile_nav closed">
					<span class="mobile_menu_bar"></span>
				</div>
			</div>
						</div>
						
					</div>
				</div>
				
				
			</div>		</div>
	</header>
	<div id="et-main-area">
	
    <div id="main-content">
    <div class="et-l et-l--body">
			<div class="et_builder_inner_content et_pb_gutters3"><div class="et_pb_section et_pb_section_0_tb_body et_pb_with_background et_section_regular" >
				
				
				
				
					<div class="et_pb_row et_pb_row_0_tb_body">
				<div class="et_pb_column et_pb_column_2_3 et_pb_column_0_tb_body  et_pb_css_mix_blend_mode_passthrough">
				
				
				<div class="et_pb_module et_pb_image et_pb_image_0_tb_body">
				
				
				<a href="https://publisher.etype.services/Princeton-Herald" target="_blank"><span class="et_pb_image_wrap "><img loading="lazy" width="728" height="90" src="https://princetonherald.com/wp-content/uploads/2021/08/AN-Local_728x90-1.jpg" alt="Read Local" title="Subscribe_2020_PH_read local-3-verified_300x250-2" srcset="https://princetonherald.com/wp-content/uploads/2021/08/AN-Local_728x90-1.jpg 728w, https://princetonherald.com/wp-content/uploads/2021/08/AN-Local_728x90-1-480x59.jpg 480w" sizes="(min-width: 0px) and (max-width: 480px) 480px, (min-width: 481px) 728px, 100vw" class="wp-image-14356" data-et-multi-view="{&quot;schema&quot;:{&quot;attrs&quot;:{&quot;desktop&quot;:{&quot;src&quot;:&quot;https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/AN-Local_728x90-1.jpg&quot;,&quot;alt&quot;:&quot;Read Local&quot;,&quot;title&quot;:&quot;Subscribe_2020_PH_read local-3-verified_300x250-2&quot;,&quot;class&quot;:&quot;wp-image-14356&quot;,&quot;srcset&quot;:&quot;https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/AN-Local_728x90-1.jpg 728w, https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/AN-Local_728x90-1-480x59.jpg 480w&quot;,&quot;sizes&quot;:&quot;(min-width: 0px) and (max-width: 480px) 480px, (min-width: 481px) 728px, 100vw&quot;},&quot;phone&quot;:{&quot;src&quot;:&quot;https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Subscribe_2020_PH_read-local-3-verified_300x250-2.jpg&quot;}}},&quot;slug&quot;:&quot;et_pb_image&quot;}" /></span></a>
			</div><div class="et_pb_module et_pb_post_title et_pb_post_title_0_tb_body et_pb_bg_layout_light  et_pb_text_align_left"   >
				
				
				
				<div class="et_pb_title_container">
					<h1 class="entry-title">Early voting ends Friday; Election Day is Tuesday, Nov. 8</h1><p class="et_pb_title_meta_container"> by <span class="author vcard"><a href="https://princetonherald.com/author/staffreports/" title="Posts by Staff Reports" rel="author">Staff Reports</a></span> | <span class="published">Nov 2, 2022</span> | <a href="https://princetonherald.com/category/latest/" rel="category tag">Latest</a>, <a href="https://princetonherald.com/category/news/" rel="category tag">News</a></p>
				</div>
				
			</div><div class="et_pb_module et_pb_post_title et_pb_post_title_1_tb_body et_pb_bg_layout_light  et_pb_text_align_left"   >
				
				
				
				<div class="et_pb_title_container">
					
				</div>
				<div class="et_pb_title_featured_container"><span class="et_pb_image_wrap"><img loading="lazy" width="1065" height="710" src="https://princetonherald.com/wp-content/uploads/2019/07/election.jpg" alt="" title="election" srcset="https://princetonherald.com/wp-content/uploads/2019/07/election.jpg 1065w, https://princetonherald.com/wp-content/uploads/2019/07/election-300x200.jpg 300w, https://princetonherald.com/wp-content/uploads/2019/07/election-768x512.jpg 768w, https://princetonherald.com/wp-content/uploads/2019/07/election-1024x683.jpg 1024w, https://princetonherald.com/wp-content/uploads/2019/07/election-90x60.jpg 90w, https://princetonherald.com/wp-content/uploads/2019/07/election-180x120.jpg 180w, https://princetonherald.com/wp-content/uploads/2019/07/election-95x64.jpg 95w" sizes="(max-width: 1065px) 100vw, 1065px" class="wp-image-4543" /></span></div>
			</div><div class="et_pb_module et_pb_post_content et_pb_post_content_0_tb_body">
				
				
				
<p>Early voting will close <strong>Friday, Nov. 4</strong> and Election Day is <strong>Tuesday, Nov. 8</strong> for the November midterm elections and for 37 races at the county, state and federal level.</p>



<p>On Election Day, the polls will be open from 7 a.m. until 7 p.m.</p>



<p>At the local level, residents within <strong>Princeton ISD will vote to elect two trustees</strong> from a pool of four candidates. In the election, the two candidates who win the most votes will assume the positions.</p>



<p>Incumbent Starla Sharpe, candidate Tim Tidwell, candidate Julia Schmoker and candidate John Campbell will vie for the two vacant positions. The candidates do not run with a party affiliation.</p>



<p>Additionally, residents will cast their ballot on a <strong>Home Rule Charter</strong>. Typically, cities make the transition from general law to home rule after reaching 5,000 residents but the measure has failed four times with the most recent attempt in 2014.</p>



<p>Approving the Home Rule Charter is an all-or-nothing process which means that voters must either vote to approve the entire charter as presented or vote against. Voters can view a copy of the charter in English or Spanish by visiting princetontx.gov.</p>



<p>At the county level, in the race for Collin County Justice of the Peace, Precinct 2, Democrat Jennifer McKenzie faces Republican Ellen Skinner.</p>



<p>In the Collin County Judge race, Republican incumbent Chris Hill is opposed by Democratic nominee Joshua Murray. The race for Collin County District Clerk pits Democrat David Brignac against Republican Mike Gould.</p>



<p>Also in Collin County, there are multiple unopposed races for district court judge positions up for re-election.</p>



<p>Residents will also vote for their U.S. Representative for District 3 which pits former Collin County Judge, Republican Keith Self, against Democratic nominee Sandeep Srivastava and Libertarian Chris Claytor.</p>



<p>Those living in Princeton will vote in the race for District 67 in the Texas House of Representatives, which pits Republican Jeff Leach against Democratic challenger Kevin Morris.</p>



<p>In State Senate District 8, Republican Angela Paxton, the incumbent, faces off against Democratic nominee Jonathan Cocks and Libertarian Edward Kless.</p>



<p>On the State Board of Education, District 12 is up for reelection. Republican Pam Little is opposed by Democrat Alex Cornwallis and Libertarian Christy Mowrey. The 15-member board decides curriculum, standards, student testing, special education programs and textbooks for public schools.</p>



<p>The race for Texas Supreme Court Justice has three places up for election. Place 3 has three candidates vying for the spot: Republican Debra Lehrman, Democrat Erin Nowell and Libertarian Thomas Edward. In Place 5, Republican Rebecca Huddle faces Democrat Amanda Reichek and Place 9 candidates are Republican Evan Young versus Democrat Julia Maldonado.</p>



<p>In the race for governor, Republican Greg Abbott faces Beto O’Rourke, his Democratic challenger. Abbott and O’Rourke will compete for votes against Libertarian candidate Mark Tippetts and Green Party candidate Delilah Barrios.</p>



<p>In the lieutenant governor’s race, Republican Dan Patrick faces Mike Collier, who is running as the Democratic nominee. Patrick and Collier share the ballot with Libertarian candidate Shanna Steele.</p>



<p>Voters will also have their say in the race for attorney general. Two-term Republican Ken Paxton is opposed by Democratic candidate Rochelle Mercedes Garza and Libertarian candidate Mark Ash. In the race for State Comptroller, Glenn Hegar is opposed by Janet T. Dudding and Libertarian V. Alonzo Echevarria-Garza.</p>



<p>The race for Railroad Commissioner has four candidates vying for the spot: Republican Wayne Christian, Democrat Luke Warford, Libertarian Jaime Andres and Hunter Wayne, who represents the Green Party.</p>



<p>Polling places include the Steve and Judy Deffibaugh Community Center, 416 N. Fourth St. in Princeton and Collin College’s Farmersville Campus, which is located at 501 S. Collin Parkway.</p>



<p>Registered voters can visit collincountytx.gov to find additional Election Day voting information.</p>

			</div><div class="et_pb_module et_pb_image et_pb_image_1_tb_body">
				
				
				<a href="https://publisher.etype.services/Princeton-Herald" target="_blank"><span class="et_pb_image_wrap "><img loading="lazy" width="728" height="90" src="https://princetonherald.com/wp-content/uploads/2021/08/Vet-Nov-10-issue-300x250-2.png" alt="Veterans" title="Vet-Nov 10 issue-300x250" srcset="https://princetonherald.com/wp-content/uploads/2021/08/Vet-Nov-10-issue-300x250-2.png 728w, https://princetonherald.com/wp-content/uploads/2021/08/Vet-Nov-10-issue-300x250-2-480x59.png 480w" sizes="(min-width: 0px) and (max-width: 480px) 480px, (min-width: 481px) 728px, 100vw" class="wp-image-15006" data-et-multi-view="{&quot;schema&quot;:{&quot;attrs&quot;:{&quot;desktop&quot;:{&quot;src&quot;:&quot;https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Vet-Nov-10-issue-300x250-2.png&quot;,&quot;alt&quot;:&quot;Veterans&quot;,&quot;title&quot;:&quot;Vet-Nov 10 issue-300x250&quot;,&quot;class&quot;:&quot;wp-image-15006&quot;,&quot;srcset&quot;:&quot;https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Vet-Nov-10-issue-300x250-2.png 728w, https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Vet-Nov-10-issue-300x250-2-480x59.png 480w&quot;,&quot;sizes&quot;:&quot;(min-width: 0px) and (max-width: 480px) 480px, (min-width: 481px) 728px, 100vw&quot;},&quot;phone&quot;:{&quot;src&quot;:&quot;https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Vet-Nov-10-issue-300x250-1.png&quot;}}},&quot;slug&quot;:&quot;et_pb_image&quot;}" /></span></a>
			</div><div class="et_pb_module et_pb_comments_0_tb_body et_pb_comments_module et_pb_bg_layout_light">
				
				
				

<section id="comment-wrap">
	<h1 id="comments" class="page_title">0 Comments</h1>
		   <div id="comment-section" class="nocomments">
		  
		  	   </div>
		
	</section>

			</div><div class="et_pb_module et_pb_image et_pb_image_2_tb_body">
				
				
				<a href="https://publisher.etype.services/Princeton-Herald" target="_blank"><span class="et_pb_image_wrap "><img loading="lazy" width="728" height="90" src="https://princetonherald.com/wp-content/uploads/2021/08/Subscribe_2020_PH_read-local_5-community728x90-1.jpg" alt="" title="Subscribe_2020_PH_read local-5-community_300x250-2" srcset="https://princetonherald.com/wp-content/uploads/2021/08/Subscribe_2020_PH_read-local_5-community728x90-1.jpg 728w, https://princetonherald.com/wp-content/uploads/2021/08/Subscribe_2020_PH_read-local_5-community728x90-1-480x59.jpg 480w" sizes="(min-width: 0px) and (max-width: 480px) 480px, (min-width: 481px) 728px, 100vw" class="wp-image-14178" data-et-multi-view="{&quot;schema&quot;:{&quot;attrs&quot;:{&quot;desktop&quot;:{&quot;src&quot;:&quot;https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Subscribe_2020_PH_read-local_5-community728x90-1.jpg&quot;,&quot;alt&quot;:&quot;&quot;,&quot;title&quot;:&quot;Subscribe_2020_PH_read local-5-community_300x250-2&quot;,&quot;class&quot;:&quot;wp-image-14178&quot;,&quot;srcset&quot;:&quot;https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Subscribe_2020_PH_read-local_5-community728x90-1.jpg 728w, https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Subscribe_2020_PH_read-local_5-community728x90-1-480x59.jpg 480w&quot;,&quot;sizes&quot;:&quot;(min-width: 0px) and (max-width: 480px) 480px, (min-width: 481px) 728px, 100vw&quot;},&quot;phone&quot;:{&quot;src&quot;:&quot;https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Subscribe_2020_PH_read-local-5-community_300x250-2.jpg&quot;}}},&quot;slug&quot;:&quot;et_pb_image&quot;}" /></span></a>
			</div><div class="et_pb_with_border et_pb_module et_pb_text et_pb_text_0_tb_body  et_pb_text_align_left et_pb_bg_layout_light">
				
				
				<div class="et_pb_text_inner"><p>Related News</p></div>
			</div><div class="et_pb_with_border et_pb_module et_pb_blog_0_tb_body et_pb_blog_grid_wrapper et_pb_bg_layout_light">
					<div class="et_pb_blog_grid clearfix ">
					
					
					<div class="et_pb_ajax_pagination_container">
						<div class="et_pb_salvattore_content" data-columns>
			<article id="post-14989" class="et_pb_post clearfix et_pb_has_overlay et_pb_blog_item_0_0 post-14989 post type-post status-publish format-standard has-post-thumbnail hentry category-latest">

				<div class="et_pb_image_container"><a href="https://princetonherald.com/2022/11/03/mayor-hopes-to-educate-voters-on-upcoming-home-rule/" class="entry-featured-image-url"><img loading="lazy" src="https://princetonherald.com/wp-content/uploads/2020/11/mayor.jpg" alt="Mayor hopes to educate voters on upcoming home rule" class="" srcset="https://princetonherald.com/wp-content/uploads/2020/11/mayor.jpg 479w, https://princetonherald.com/wp-content/uploads/2020/11/mayor.jpg 480w " sizes="(max-width:479px) 479px, 100vw "  width="400" height="250" /><span class="et_overlay et_pb_inline_icon" data-icon="&#xe050;"></span></a></div>
														<h2 class="entry-title"><a href="https://princetonherald.com/2022/11/03/mayor-hopes-to-educate-voters-on-upcoming-home-rule/">Mayor hopes to educate voters on upcoming home rule</a></h2>
				
					<p class="post-meta"><span class="published">Nov 3, 2022</span> | <a href="https://princetonherald.com/category/latest/" rel="tag">Latest</a></p><div class="post-content"><div class="post-content-inner et_multi_view_hidden"><p>Princeton Mayor Brianna Chacon vowed to take on the task herself if no one would agree to lead a citizen effort to gain approval of a home rule charter for the city. Chacon has made good on her pledge, she said in explaining that she is leading an “unofficial PAC”...</p>
</div><a href="https://princetonherald.com/2022/11/03/mayor-hopes-to-educate-voters-on-upcoming-home-rule/" class="more-link">read more</a></div>			
			</article>
				
			<article id="post-14985" class="et_pb_post clearfix et_pb_has_overlay et_pb_blog_item_0_1 post-14985 post type-post status-publish format-standard has-post-thumbnail hentry category-latest tag-home-rule-charter tag-princeton-tx">

				<div class="et_pb_image_container"><a href="https://princetonherald.com/2022/11/02/city-encourages-voters-to-get-accurate-information-about-home-rule-charter/" class="entry-featured-image-url"><img loading="lazy" src="https://princetonherald.com/wp-content/uploads/2022/01/IMG_1813-digital-400x250.jpg" alt="City encourages voters to get accurate information about home rule charter" class="" srcset="https://princetonherald.com/wp-content/uploads/2022/01/IMG_1813-digital.jpg 479w, https://princetonherald.com/wp-content/uploads/2022/01/IMG_1813-digital-400x250.jpg 480w " sizes="(max-width:479px) 479px, 100vw "  width="400" height="250" /><span class="et_overlay et_pb_inline_icon" data-icon="&#xe050;"></span></a></div>
														<h2 class="entry-title"><a href="https://princetonherald.com/2022/11/02/city-encourages-voters-to-get-accurate-information-about-home-rule-charter/">City encourages voters to get accurate information about home rule charter</a></h2>
				
					<p class="post-meta"><span class="published">Nov 2, 2022</span> | <a href="https://princetonherald.com/category/latest/" rel="tag">Latest</a></p><div class="post-content"><div class="post-content-inner et_multi_view_hidden"><p>Princeton City Manager Derek Borg has issued a reply to what he calls “erroneous information” being distributed concerning the home rule charter proposal for the city that will be decided next Tuesday, Nov. 8 in a city election. Borg said in a statement that the city...</p>
</div><a href="https://princetonherald.com/2022/11/02/city-encourages-voters-to-get-accurate-information-about-home-rule-charter/" class="more-link">read more</a></div>			
			</article>
				
			<article id="post-14982" class="et_pb_post clearfix et_pb_has_overlay et_pb_blog_item_0_2 post-14982 post type-post status-publish format-standard has-post-thumbnail hentry category-latest tag-top">

				<div class="et_pb_image_container"><a href="https://princetonherald.com/2022/11/01/federal-lawsuit-alleges-sexual-harassment-retaliation-by-collin-county-da-first-assistant-da/" class="entry-featured-image-url"><img loading="lazy" src="https://princetonherald.com/wp-content/uploads/2021/07/Collin-County-Courthouse-400x250.jpg" alt="Federal lawsuit alleges sexual harassment, retaliation by Collin County DA, First Assistant DA" class="" srcset="https://princetonherald.com/wp-content/uploads/2021/07/Collin-County-Courthouse.jpg 479w, https://princetonherald.com/wp-content/uploads/2021/07/Collin-County-Courthouse-400x250.jpg 480w " sizes="(max-width:479px) 479px, 100vw "  width="400" height="250" /><span class="et_overlay et_pb_inline_icon" data-icon="&#xe050;"></span></a></div>
														<h2 class="entry-title"><a href="https://princetonherald.com/2022/11/01/federal-lawsuit-alleges-sexual-harassment-retaliation-by-collin-county-da-first-assistant-da/">Federal lawsuit alleges sexual harassment, retaliation by Collin County DA, First Assistant DA</a></h2>
				
					<p class="post-meta"><span class="published">Nov 1, 2022</span> | <a href="https://princetonherald.com/category/latest/" rel="tag">Latest</a></p><div class="post-content"><div class="post-content-inner et_multi_view_hidden"><p>Both current and former employees of Collin County District Attorney Greg Willis alleged that he and his top lieutenant — First Assistant District Attorney Bill Wirskye — created a toxic workplace by sexually harrassing and retaliating against female coworkers. The...</p>
</div><a href="https://princetonherald.com/2022/11/01/federal-lawsuit-alleges-sexual-harassment-retaliation-by-collin-county-da-first-assistant-da/" class="more-link">read more</a></div>			
			</article>
				
			<article id="post-14967" class="et_pb_post clearfix et_pb_has_overlay et_pb_blog_item_0_3 post-14967 post type-post status-publish format-standard has-post-thumbnail hentry category-latest category-news tag-tickey-creek tag-tree-planting">

				<div class="et_pb_image_container"><a href="https://princetonherald.com/2022/10/26/forests-to-faucets-is-friday/" class="entry-featured-image-url"><img loading="lazy" src="https://princetonherald.com/wp-content/uploads/2022/10/N2204P43002H-400x250.jpg" alt="Forests to Faucets is Nov. 4" class="" srcset="https://princetonherald.com/wp-content/uploads/2022/10/N2204P43002H.jpg 479w, https://princetonherald.com/wp-content/uploads/2022/10/N2204P43002H-400x250.jpg 480w " sizes="(max-width:479px) 479px, 100vw "  width="400" height="250" /><span class="et_overlay et_pb_inline_icon" data-icon="&#xe050;"></span></a></div>
														<h2 class="entry-title"><a href="https://princetonherald.com/2022/10/26/forests-to-faucets-is-friday/">Forests to Faucets is Nov. 4</a></h2>
				
					<p class="post-meta"><span class="published">Oct 26, 2022</span> | <a href="https://princetonherald.com/category/latest/" rel="tag">Latest</a>, <a href="https://princetonherald.com/category/news/" rel="tag">News</a></p><div class="post-content"><div class="post-content-inner et_multi_view_hidden"><p>The city of Princeton needs your help to plant over 1,200 trees along Tickey Creek to help protect water — its most important resource. The Tickey Creek Tree Planting Event will be held from 9 a.m. to noon Friday, Nov. 4 . If it rains, the event will be pushed to Nov....</p>
</div><a href="https://princetonherald.com/2022/10/26/forests-to-faucets-is-friday/" class="more-link">read more</a></div>			
			</article>
				
			<article id="post-14964" class="et_pb_post clearfix et_pb_has_overlay et_pb_blog_item_0_4 post-14964 post type-post status-publish format-standard has-post-thumbnail hentry category-education category-latest">

				<div class="et_pb_image_container"><a href="https://princetonherald.com/2022/10/26/new-marshals-added-to-pisd-security-team/" class="entry-featured-image-url"><img loading="lazy" src="https://princetonherald.com/wp-content/uploads/2021/12/Princeton-HS-digital-400x250.jpg" alt="New marshals added to PISD security team" class="" srcset="https://princetonherald.com/wp-content/uploads/2021/12/Princeton-HS-digital.jpg 479w, https://princetonherald.com/wp-content/uploads/2021/12/Princeton-HS-digital-400x250.jpg 480w " sizes="(max-width:479px) 479px, 100vw "  width="400" height="250" /><span class="et_overlay et_pb_inline_icon" data-icon="&#xe050;"></span></a></div>
														<h2 class="entry-title"><a href="https://princetonherald.com/2022/10/26/new-marshals-added-to-pisd-security-team/">New marshals added to PISD security team</a></h2>
				
					<p class="post-meta"><span class="published">Oct 26, 2022</span> | <a href="https://princetonherald.com/category/education/" rel="tag">Education</a>, <a href="https://princetonherald.com/category/latest/" rel="tag">Latest</a></p><div class="post-content"><div class="post-content-inner et_multi_view_hidden"><p>Three school marshals will be added to the ranks of Princeton ISD’s security team. The new positions were approved at the Oct. 17 trustee meeting. The district’s goal is to assign a marshal to each school campus. Superintendent Don McIntyre was pleased with the...</p>
</div><a href="https://princetonherald.com/2022/10/26/new-marshals-added-to-pisd-security-team/" class="more-link">read more</a></div>			
			</article>
				
			<article id="post-14958" class="et_pb_post clearfix et_pb_has_overlay et_pb_blog_item_0_5 post-14958 post type-post status-publish format-standard has-post-thumbnail hentry category-life-style category-news">

				<div class="et_pb_image_container"><a href="https://princetonherald.com/2022/10/25/loya-recognized-for-life-saving-actions/" class="entry-featured-image-url"><img loading="lazy" src="https://princetonherald.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-11.59.51-AM-400x250.png" alt="Loya recognized for life-saving actions" class="" srcset="https://princetonherald.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-11.59.51-AM.png 479w, https://princetonherald.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-11.59.51-AM-400x250.png 480w " sizes="(max-width:479px) 479px, 100vw "  width="400" height="250" /><span class="et_overlay et_pb_inline_icon" data-icon="&#xe050;"></span></a></div>
														<h2 class="entry-title"><a href="https://princetonherald.com/2022/10/25/loya-recognized-for-life-saving-actions/">Loya recognized for life-saving actions</a></h2>
				
					<p class="post-meta"><span class="published">Oct 25, 2022</span> | <a href="https://princetonherald.com/category/life-style/" rel="tag">Life &amp; Style</a>, <a href="https://princetonherald.com/category/news/" rel="tag">News</a></p><div class="post-content"><div class="post-content-inner et_multi_view_hidden"><p>Princeton police officer Armando Loya was recognized with a Certificate of Merit at Monday night’s city council meeting. His life-saving actions on Feb 10, 2022 while responding to a call involving a one-year old who had fallen and become unresponsive, were described...</p>
</div><a href="https://princetonherald.com/2022/10/25/loya-recognized-for-life-saving-actions/" class="more-link">read more</a></div>			
			</article>
				
			<article id="post-14955" class="et_pb_post clearfix et_pb_has_overlay et_pb_blog_item_0_6 post-14955 post type-post status-publish format-standard has-post-thumbnail hentry category-latest tag-top">

				<div class="et_pb_image_container"><a href="https://princetonherald.com/2022/10/24/early-voting-begins-today-2/" class="entry-featured-image-url"><img loading="lazy" src="https://princetonherald.com/wp-content/uploads/2020/11/Vote.jpg" alt="Early voting begins today" class="" srcset="https://princetonherald.com/wp-content/uploads/2020/11/Vote.jpg 479w, https://princetonherald.com/wp-content/uploads/2020/11/Vote.jpg 480w " sizes="(max-width:479px) 479px, 100vw "  width="400" height="250" /><span class="et_overlay et_pb_inline_icon" data-icon="&#xe050;"></span></a></div>
														<h2 class="entry-title"><a href="https://princetonherald.com/2022/10/24/early-voting-begins-today-2/">Early voting begins today</a></h2>
				
					<p class="post-meta"><span class="published">Oct 24, 2022</span> | <a href="https://princetonherald.com/category/latest/" rel="tag">Latest</a></p><div class="post-content"><div class="post-content-inner et_multi_view_hidden"><p>Voters across Texas are heading to the polls to cast their ballots for races in the 2022 election.&nbsp; On the ballot are federal, state, county and city officials including the governor, county judge and state representative races. Some cities will also vote on...</p>
</div><a href="https://princetonherald.com/2022/10/24/early-voting-begins-today-2/" class="more-link">read more</a></div>			
			</article>
				
			<article id="post-14953" class="et_pb_post clearfix et_pb_has_overlay et_pb_blog_item_0_7 post-14953 post type-post status-publish format-standard has-post-thumbnail hentry category-latest category-sports">

				<div class="et_pb_image_container"><a href="https://princetonherald.com/2022/10/22/princeton-struggles-continue-in-loss-to-denison/" class="entry-featured-image-url"><img loading="lazy" src="https://princetonherald.com/wp-content/uploads/2020/10/FB_PHS.jpg" alt="Princeton struggles continue in loss to Denison" class="" srcset="https://princetonherald.com/wp-content/uploads/2020/10/FB_PHS.jpg 479w, https://princetonherald.com/wp-content/uploads/2020/10/FB_PHS.jpg 480w " sizes="(max-width:479px) 479px, 100vw "  width="400" height="250" /><span class="et_overlay et_pb_inline_icon" data-icon="&#xe050;"></span></a></div>
														<h2 class="entry-title"><a href="https://princetonherald.com/2022/10/22/princeton-struggles-continue-in-loss-to-denison/">Princeton struggles continue in loss to Denison</a></h2>
				
					<p class="post-meta"><span class="published">Oct 22, 2022</span> | <a href="https://princetonherald.com/category/latest/" rel="tag">Latest</a>, <a href="https://princetonherald.com/category/sports/" rel="tag">Sports</a></p><div class="post-content"><div class="post-content-inner et_multi_view_hidden"><p>DENISON — The Panthers (1-7) suffered a 67-26 loss to the Denison Yellow Jackets (4-4, 2-3). Princeton remains winless in district play with an 0-5 record.  While Princeton had promising drives on offense, a series of errors throughout the night kept them from putting...</p>
</div><a href="https://princetonherald.com/2022/10/22/princeton-struggles-continue-in-loss-to-denison/" class="more-link">read more</a></div>			
			</article>
				
			<article id="post-14950" class="et_pb_post clearfix et_pb_has_overlay et_pb_blog_item_0_8 post-14950 post type-post status-publish format-standard has-post-thumbnail hentry category-latest">

				<div class="et_pb_image_container"><a href="https://princetonherald.com/2022/10/21/bois-darc-lake-dedicated/" class="entry-featured-image-url"><img loading="lazy" src="https://princetonherald.com/wp-content/uploads/2022/10/Bois-dArc-Lake-Dedication-web-400x250.jpg" alt="Bois d&#8217;Arc Lake dedicated" class="" srcset="https://princetonherald.com/wp-content/uploads/2022/10/Bois-dArc-Lake-Dedication-web.jpg 479w, https://princetonherald.com/wp-content/uploads/2022/10/Bois-dArc-Lake-Dedication-web-400x250.jpg 480w " sizes="(max-width:479px) 479px, 100vw "  width="400" height="250" /><span class="et_overlay et_pb_inline_icon" data-icon="&#xe050;"></span></a></div>
														<h2 class="entry-title"><a href="https://princetonherald.com/2022/10/21/bois-darc-lake-dedicated/">Bois d&#8217;Arc Lake dedicated</a></h2>
				
					<p class="post-meta"><span class="published">Oct 21, 2022</span> | <a href="https://princetonherald.com/category/latest/" rel="tag">Latest</a></p><div class="post-content"><div class="post-content-inner et_multi_view_hidden"><p>Blue skies and an expansive view of the state’s first major reservoir built in over 30 years provided a scenic backdrop for the crowd that gathered in Fannin County for the official dedication of Bois d’Arc Lake by the North Texas Municipal Water District. The event,...</p>
</div><a href="https://princetonherald.com/2022/10/21/bois-darc-lake-dedicated/" class="more-link">read more</a></div>			
			</article>
				
			<article id="post-14948" class="et_pb_post clearfix et_pb_has_overlay et_pb_blog_item_0_9 post-14948 post type-post status-publish format-standard has-post-thumbnail hentry category-latest">

				<div class="et_pb_image_container"><a href="https://princetonherald.com/2022/10/21/future-parks-in-play-for-city/" class="entry-featured-image-url"><img loading="lazy" src="https://princetonherald.com/wp-content/uploads/2022/01/IMG_1813-digital-400x250.jpg" alt="Future parks in play for city" class="" srcset="https://princetonherald.com/wp-content/uploads/2022/01/IMG_1813-digital.jpg 479w, https://princetonherald.com/wp-content/uploads/2022/01/IMG_1813-digital-400x250.jpg 480w " sizes="(max-width:479px) 479px, 100vw "  width="400" height="250" /><span class="et_overlay et_pb_inline_icon" data-icon="&#xe050;"></span></a></div>
														<h2 class="entry-title"><a href="https://princetonherald.com/2022/10/21/future-parks-in-play-for-city/">Future parks in play for city</a></h2>
				
					<p class="post-meta"><span class="published">Oct 21, 2022</span> | <a href="https://princetonherald.com/category/latest/" rel="tag">Latest</a></p><div class="post-content"><div class="post-content-inner et_multi_view_hidden"><p>Princeton residents may well soon be able to have many more outdoor activity opportunities available to them if the city once the city proceeds with development of its master park plan. In addition, the Princeton City Council voted Oct. 11 to authorize City Manager...</p>
</div><a href="https://princetonherald.com/2022/10/21/future-parks-in-play-for-city/" class="more-link">read more</a></div>			
			</article>
				</div>
					</div>
					</div> 
				</div><div class="et_pb_module et_pb_image et_pb_image_3_tb_body">
				
				
				<a href="https://publisher.etype.services/Princeton-Herald" target="_blank"><span class="et_pb_image_wrap "><img loading="lazy" width="728" height="90" src="https://princetonherald.com/wp-content/uploads/2021/08/Subscribe_2020_PH_read-local_2-watchdog728x90-1.jpg" alt="" title="Subscribe_2020_PH_read local-2-watchdog_300x250-2" srcset="https://princetonherald.com/wp-content/uploads/2021/08/Subscribe_2020_PH_read-local_2-watchdog728x90-1.jpg 728w, https://princetonherald.com/wp-content/uploads/2021/08/Subscribe_2020_PH_read-local_2-watchdog728x90-1-480x59.jpg 480w" sizes="(min-width: 0px) and (max-width: 480px) 480px, (min-width: 481px) 728px, 100vw" class="wp-image-14175" data-et-multi-view="{&quot;schema&quot;:{&quot;attrs&quot;:{&quot;desktop&quot;:{&quot;src&quot;:&quot;https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Subscribe_2020_PH_read-local_2-watchdog728x90-1.jpg&quot;,&quot;alt&quot;:&quot;&quot;,&quot;title&quot;:&quot;Subscribe_2020_PH_read local-2-watchdog_300x250-2&quot;,&quot;class&quot;:&quot;wp-image-14175&quot;,&quot;srcset&quot;:&quot;https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Subscribe_2020_PH_read-local_2-watchdog728x90-1.jpg 728w, https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Subscribe_2020_PH_read-local_2-watchdog728x90-1-480x59.jpg 480w&quot;,&quot;sizes&quot;:&quot;(min-width: 0px) and (max-width: 480px) 480px, (min-width: 481px) 728px, 100vw&quot;},&quot;phone&quot;:{&quot;src&quot;:&quot;https:\/\/princetonherald.com\/wp-content\/uploads\/2021\/08\/Subscribe_2020_PH_read-local-2-watchdog_300x250-2.jpg&quot;}}},&quot;slug&quot;:&quot;et_pb_image&quot;}" /></span></a>
			</div>
			</div><div class="et_pb_column et_pb_column_1_3 et_pb_column_1_tb_body  et_pb_css_mix_blend_mode_passthrough et-last-child">
				
				
				<div class="et_pb_module et_pb_image et_pb_image_4_tb_body">
				
				
				<a href="https://publisher.etype.services/Princeton-Herald" target="_blank"><span class="et_pb_image_wrap "><img loading="lazy" width="300" height="250" src="https://princetonherald.com/wp-content/uploads/2021/08/Vet-Nov-10-issue-300x250-1.png" alt="Veterans" title="Vet-Nov 10 issue-300x250" class="wp-image-15008" /></span></a>
			</div><div class="et_pb_module et_pb_sidebar_0_tb_body et_pb_widget_area clearfix et_pb_widget_area_right et_pb_bg_layout_light">
				
				
				<div id="block-5" class="et_pb_widget widget_block">
<div class="wp-container-1 wp-block-group"><div class="wp-block-group__inner-container">
<h2>Sections</h2>


<ul class="wp-block-categories-list wp-block-categories">	<li class="cat-item cat-item-7"><a href="https://princetonherald.com/category/education/">Education</a>
</li>
	<li class="cat-item cat-item-8"><a href="https://princetonherald.com/category/latest/">Latest</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://princetonherald.com/category/life-style/">Life &amp; Style</a>
</li>
	<li class="cat-item cat-item-36"><a href="https://princetonherald.com/category/news/">News</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://princetonherald.com/category/occasions/">Occasions</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://princetonherald.com/category/opinion/">Opinion</a>
</li>
	<li class="cat-item cat-item-3"><a href="https://princetonherald.com/category/sports/">Sports</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://princetonherald.com/category/uncategorized/">Uncategorized</a>
</li>
</ul></div></div>
</div>
			</div><div class="et_pb_module et_pb_image et_pb_image_5_tb_body">
				
				
				<a href="https://publisher.etype.services/Princeton-Herald" target="_blank"><span class="et_pb_image_wrap "><img loading="lazy" width="300" height="250" src="https://princetonherald.com/wp-content/uploads/2021/08/Subscribe_2020_PH_read-local-4-unbiased_300x250-2.jpg" alt="" title="Subscribe_2020_PH_read local-4-unbiased_300x250-2" class="wp-image-14172" /></span></a>
			</div><div class="et_pb_module et_pb_image et_pb_image_6_tb_body">
				
				
				<a href="https://publisher.etype.services/Princeton-Herald" target="_blank"><span class="et_pb_image_wrap "><img loading="lazy" width="300" height="250" src="https://princetonherald.com/wp-content/uploads/2021/08/Vet-Nov-10-issue-300x250-1.png" alt="Veterans" title="Vet-Nov 10 issue-300x250" class="wp-image-15008" /></span></a>
			</div><div class="et_pb_module et_pb_sidebar_1_tb_body et_pb_widget_area clearfix et_pb_widget_area_right et_pb_bg_layout_light">
				
				
				<div id="block-6" class="et_pb_widget widget_block">
<div class="wp-container-2 wp-block-group"><div class="wp-block-group__inner-container">
<h2>Latest News</h2>


<ul class="wp-block-latest-posts__list wp-block-latest-posts"><li><a href="https://princetonherald.com/2022/11/03/mayor-hopes-to-educate-voters-on-upcoming-home-rule/">Mayor hopes to educate voters on upcoming home rule</a></li>
<li><a href="https://princetonherald.com/2022/11/02/early-voting-ends-friday-election-day-is-tuesday-nov-8/">Early voting ends Friday; Election Day is Tuesday, Nov. 8</a></li>
<li><a href="https://princetonherald.com/2022/11/02/city-encourages-voters-to-get-accurate-information-about-home-rule-charter/">City encourages voters to get accurate information about home rule charter</a></li>
<li><a href="https://princetonherald.com/2022/11/01/federal-lawsuit-alleges-sexual-harassment-retaliation-by-collin-county-da-first-assistant-da/">Federal lawsuit alleges sexual harassment, retaliation by Collin County DA, First Assistant DA</a></li>
<li><a href="https://princetonherald.com/2022/10/26/forests-to-faucets-is-friday/">Forests to Faucets is Nov. 4</a></li>
</ul></div></div>
</div>
			</div><div class="et_pb_module et_pb_image et_pb_image_7_tb_body">
				
				
				<a href="https://publisher.etype.services/Princeton-Herald" target="_blank"><span class="et_pb_image_wrap "><img loading="lazy" width="300" height="250" src="https://princetonherald.com/wp-content/uploads/2021/08/Subscribe_2020_PH_read-local-5-community_300x250-2.jpg" alt="" title="Subscribe_2020_PH_read local-5-community_300x250-2" class="wp-image-14173" /></span></a>
			</div><div class="et_pb_module et_pb_image et_pb_image_8_tb_body">
				
				
				<a href="https://publisher.etype.services/Princeton-Herald" target="_blank"><span class="et_pb_image_wrap "><img loading="lazy" width="300" height="250" src="https://princetonherald.com/wp-content/uploads/2021/08/Vet-Nov-10-issue-300x250-1.png" alt="Veterans" title="Vet-Nov 10 issue-300x250" class="wp-image-15008" /></span></a>
			</div><div class="et_pb_module et_pb_sidebar_2_tb_body et_pb_widget_area clearfix et_pb_widget_area_right et_pb_bg_layout_light">
				
				
				
			</div><div class="et_pb_module et_pb_image et_pb_image_9_tb_body">
				
				
				<a href="https://publisher.etype.services/Princeton-Herald" target="_blank"><span class="et_pb_image_wrap "><img loading="lazy" width="300" height="250" src="https://princetonherald.com/wp-content/uploads/2021/08/Subscribe_2020_PH_read-local-4-unbiased_300x250-2.jpg" alt="" title="Subscribe_2020_PH_read local-4-unbiased_300x250-2" class="wp-image-14172" /></span></a>
			</div><div class="et_pb_module et_pb_image et_pb_image_10_tb_body">
				
				
				<a href="https://publisher.etype.services/Princeton-Herald" target="_blank"><span class="et_pb_image_wrap "><img loading="lazy" width="300" height="250" src="https://princetonherald.com/wp-content/uploads/2021/08/Vet-Nov-10-issue-300x250-1.png" alt="Veterans" title="Vet-Nov 10 issue-300x250" class="wp-image-15008" /></span></a>
			</div><div class="et_pb_module et_pb_image et_pb_image_11_tb_body">
				
				
				<a href="https://publisher.etype.services/Princeton-Herald" target="_blank"><span class="et_pb_image_wrap "><img loading="lazy" width="300" height="250" src="https://princetonherald.com/wp-content/uploads/2021/08/Vet-Nov-10-issue-300x250-1.png" alt="Veterans" title="Vet-Nov 10 issue-300x250" class="wp-image-15008" /></span></a>
			</div>
			</div>
				
				
			</div>
				
				
			</div>		</div>
	</div>
	    </div>
    
	<footer class="et-l et-l--footer">
			<div class="et_builder_inner_content et_pb_gutters3">
		<div class="et_pb_with_border et_pb_section et_pb_section_0_tb_footer et_pb_with_background et_section_regular" >
				
				
				
				
					<div class="et_pb_row et_pb_row_0_tb_footer">
				<div class="et_pb_column et_pb_column_3_4 et_pb_column_0_tb_footer  et_pb_css_mix_blend_mode_passthrough et_pb_column_empty">
				
				
				
			</div><div class="et_pb_column et_pb_column_1_4 et_pb_column_1_tb_footer  et_pb_css_mix_blend_mode_passthrough et-last-child">
				
				
				<div class="et_pb_module et_pb_text et_pb_text_0_tb_footer et_clickable  et_pb_text_align_right et_pb_text_align_center-tablet et_pb_bg_layout_dark">
				
				
				
			</div>
			</div>
				
				
			</div>
				
				
			</div><div class="et_pb_with_border et_pb_section et_pb_section_1_tb_footer et_pb_with_background et_section_regular" >
				
				
				
				
					<div class="et_pb_row et_pb_row_1_tb_footer">
				<div class="et_pb_column et_pb_column_1_5 et_pb_column_2_tb_footer  et_pb_css_mix_blend_mode_passthrough">
				
				
				<div class="et_pb_module et_pb_sidebar_0_tb_footer et_clickable et_pb_widget_area clearfix et_pb_widget_area_right  et_pb_text_align_center et_pb_bg_layout_light et_pb_sidebar_no_border">
				
				
				<div id="nav_menu-2" class="fwidget et_pb_widget widget_nav_menu"><h4 class="title">C&#038;S Media Publications</h4><div class="menu-publications-container"><ul id="menu-publications" class="menu"><li id="menu-item-7882" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7882"><a target="_blank" rel="noopener" href="http://farmersvilletimes.com/">The Farmersvilles Times</a></li>
<li id="menu-item-7883" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7883"><a target="_blank" rel="noopener" href="http://murphymonitor.com/">Murphy Monitor</a></li>
<li id="menu-item-7884" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-7884"><a target="_blank" rel="noopener" href="https://princetonherald.com/">The Princeton Herald</a></li>
<li id="menu-item-7885" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7885"><a target="_blank" rel="noopener" href="http://sachsenews.com/">The Sachse News</a></li>
<li id="menu-item-7886" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7886"><a target="_blank" rel="noopener" href="https://wylienews.com/">The Wylie News</a></li>
<li id="menu-item-7887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7887"><a target="_blank" rel="noopener" href="http://csmediatexas.com/">C&#038;S Media</a></li>
<li id="menu-item-12981" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12981"><a target="_blank" rel="noopener" href="http://inaroundmag.com/">In &#038; Around Magazine</a></li>
</ul></div></div>
			</div>
			</div><div class="et_pb_column et_pb_column_1_5 et_pb_column_3_tb_footer  et_pb_css_mix_blend_mode_passthrough">
				
				
				<div class="et_pb_module et_pb_sidebar_1_tb_footer et_pb_widget_area clearfix et_pb_widget_area_right  et_pb_text_align_center et_pb_bg_layout_light et_pb_sidebar_no_border">
				
				
				<div id="nav_menu-3" class="fwidget et_pb_widget widget_nav_menu"><h4 class="title">Sections</h4><div class="menu-footer-sections-container"><ul id="menu-footer-sections" class="menu"><li id="menu-item-12991" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12991"><a href="https://princetonherald.com/category/latest/">Latest</a></li>
<li id="menu-item-12992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12992"><a href="https://princetonherald.com/category/sports/">Sports</a></li>
<li id="menu-item-12993" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12993"><a href="https://princetonherald.com/category/education/">Education</a></li>
<li id="menu-item-12995" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12995"><a href="https://princetonherald.com/category/opinion/">Opinion</a></li>
<li id="menu-item-12994" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12994"><a href="https://princetonherald.com/category/life-style/">Life &amp; Style</a></li>
<li id="menu-item-12996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12996"><a href="https://princetonherald.com/category/obituaries/">Obituaries</a></li>
<li id="menu-item-13012" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13012"><a target="_blank" rel="noopener" href="https://etypeservices.com/ClassifiedUsers/CustomLogin.aspx?PID=245">Classifieds</a></li>
<li id="menu-item-12997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12997"><a href="https://princetonherald.com/category/public-notices/">Public Notices</a></li>
</ul></div></div>
			</div>
			</div><div class="et_pb_column et_pb_column_1_5 et_pb_column_4_tb_footer  et_pb_css_mix_blend_mode_passthrough">
				
				
				<div class="et_pb_module et_pb_sidebar_2_tb_footer et_pb_widget_area clearfix et_pb_widget_area_right  et_pb_text_align_center et_pb_bg_layout_light et_pb_sidebar_no_border">
				
				
				<div id="nav_menu-4" class="fwidget et_pb_widget widget_nav_menu"><h4 class="title">Media</h4><div class="menu-media-container"><ul id="menu-media" class="menu"><li id="menu-item-12999" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12999"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald">Subscribe</a></li>
<li id="menu-item-13000" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13000"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald/archives">Issues</a></li>
<li id="menu-item-13001" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13001"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald/archives">Archives</a></li>
<li id="menu-item-13002" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13002"><a target="_blank" rel="noopener" href="http://csmedia.mycapture.com/mycapture/index.asp">Photos</a></li>
</ul></div></div>
			</div>
			</div><div class="et_pb_column et_pb_column_1_5 et_pb_column_5_tb_footer  et_pb_css_mix_blend_mode_passthrough">
				
				
				<div class="et_pb_module et_pb_sidebar_3_tb_footer et_pb_widget_area clearfix et_pb_widget_area_right  et_pb_text_align_center et_pb_bg_layout_light et_pb_sidebar_no_border">
				
				
				<div id="nav_menu-5" class="fwidget et_pb_widget widget_nav_menu"><h4 class="title">Advertise</h4><div class="menu-advertise-container"><ul id="menu-advertise" class="menu"><li id="menu-item-12998" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12998"><a target="_blank" rel="noopener" href="https://etypeservices.com/ClassifiedUsers/CustomLogin.aspx?PID=245">Classifieds</a></li>
<li id="menu-item-12979" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12979"><a target="_blank" rel="noopener" href="https://publisher.etype.services/Princeton-Herald/Special-Editions">Special Sections</a></li>
<li id="menu-item-12980" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12980"><a target="_blank" rel="noopener" href="https://csmediatexas.com/princeton-media-kit/">Media Kit</a></li>
</ul></div></div>
			</div>
			</div><div class="et_pb_column et_pb_column_1_5 et_pb_column_6_tb_footer  et_pb_css_mix_blend_mode_passthrough et-last-child">
				
				
				<div class="et_pb_module et_pb_sidebar_4_tb_footer et_pb_widget_area clearfix et_pb_widget_area_right  et_pb_text_align_center et_pb_bg_layout_light et_pb_sidebar_no_border">
				
				
				<div id="nav_menu-6" class="fwidget et_pb_widget widget_nav_menu"><h4 class="title">About</h4><div class="menu-about-container"><ul id="menu-about" class="menu"><li id="menu-item-13014" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13014"><a href="https://princetonherald.com/about-us/">About Us</a></li>
<li id="menu-item-13015" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13015"><a href="https://princetonherald.com/locations/">News Rack Locations</a></li>
<li id="menu-item-13017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13017"><a href="https://princetonherald.com/contact-us/">Contact Us</a></li>
</ul></div></div>
			</div>
			</div>
				
				
			</div><div class="et_pb_with_border et_pb_row et_pb_row_2_tb_footer et_pb_equal_columns">
				<div class="et_pb_column et_pb_column_1_3 et_pb_column_7_tb_footer  et_pb_css_mix_blend_mode_passthrough">
				
				
				<div class="et_pb_module et_pb_sidebar_5_tb_footer et_pb_widget_area clearfix et_pb_widget_area_right  et_pb_text_align_center et_pb_bg_layout_light et_pb_sidebar_no_border">
				
				
				<div id="block-2" class="et_pb_widget widget_block">
<div class="wp-container-3 wp-block-group"><div class="wp-block-group__inner-container">
<h4>Mailing Address</h4>



<p><a rel="noreferrer noopener" href="https://goo.gl/maps/Etd1c61y97XW5otQ8" target="_blank">P.O. Box 369</a><br><a rel="noreferrer noopener" href="https://goo.gl/maps/Etd1c61y97XW5otQ8" target="_blank"> Wylie, TX 75098</a></p>
</div></div>
</div>
			</div>
			</div><div class="et_pb_column et_pb_column_1_3 et_pb_column_8_tb_footer  et_pb_css_mix_blend_mode_passthrough">
				
				
				<div class="et_pb_module et_pb_sidebar_6_tb_footer et_pb_widget_area clearfix et_pb_widget_area_right  et_pb_text_align_center et_pb_bg_layout_light et_pb_sidebar_no_border">
				
				
				<div id="block-3" class="et_pb_widget widget_block">
<div class="wp-container-4 wp-block-group"><div class="wp-block-group__inner-container">
<h4>Farmersville Office</h4>



<p><a href="tel:+19727846397">972-784-6397</a><br><a href="tel:+19727827023">972-782-7023 Fax</a><br><a rel="noreferrer noopener" href="https://goo.gl/maps/kUSLXeEeHg4RKM4G8" target="_blank">101 S. Main Street</a><br><a rel="noreferrer noopener" href="https://goo.gl/maps/kUSLXeEeHg4RKM4G8" target="_blank">Farmersville, TX 75442</a></p>
</div></div>
</div>
			</div>
			</div><div class="et_pb_column et_pb_column_1_3 et_pb_column_9_tb_footer  et_pb_css_mix_blend_mode_passthrough et-last-child">
				
				
				<div class="et_pb_module et_pb_sidebar_7_tb_footer et_pb_widget_area clearfix et_pb_widget_area_right  et_pb_text_align_center et_pb_bg_layout_light et_pb_sidebar_no_border">
				
				
				<div id="block-4" class="et_pb_widget widget_block">
<div class="wp-container-5 wp-block-group"><div class="wp-block-group__inner-container">
<h4>Wylie Office</h4>



<p><a href="tel:+19724425515">972-442-5515</a><br><a href="tel:+19724424318">972-442-4318 Fax</a><br><a rel="noreferrer noopener" href="https://goo.gl/maps/qQHr3RwSBDyXNrGG6" target="_blank">110 N. Ballard Avenue</a><br><a rel="noreferrer noopener" href="https://goo.gl/maps/qQHr3RwSBDyXNrGG6" target="_blank">Wylie, TX 75098</a></p>
</div></div>
</div>
			</div>
			</div>
				
				
			</div>
				
				
			</div><div class="et_pb_with_border et_pb_section et_pb_section_2_tb_footer et_pb_with_background et_section_regular" >
				
				
				
				
					<div class="et_pb_with_border et_pb_row et_pb_row_3_tb_footer">
				<div class="et_pb_column et_pb_column_1_2 et_pb_column_10_tb_footer  et_pb_css_mix_blend_mode_passthrough">
				
				
				<div class="et_pb_module et_pb_text et_pb_text_1_tb_footer et_clickable  et_pb_text_align_left et_pb_text_align_center-tablet et_pb_bg_layout_light">
				
				
				<div class="et_pb_text_inner">&copy; 2022 C&amp;S Media - Princeton Herald Since 1970</div>
			</div>
			</div><div class="et_pb_column et_pb_column_1_2 et_pb_column_11_tb_footer  et_pb_css_mix_blend_mode_passthrough et-last-child">
				
				
				<div class="et_pb_module et_pb_text et_pb_text_2_tb_footer et_clickable  et_pb_text_align_right et_pb_text_align_center-tablet et_pb_bg_layout_light">
				
				
				<div class="et_pb_text_inner"><p>Privacy Policy</p></div>
			</div>
			</div>
				
				
			</div>
				
				
			</div>		</div>
	</footer>
		</div>

			
		</div>
		</div>

				<script type="text/javascript">
				var et_link_options_data = [{"class":"et_pb_text_0_tb_footer","url":"#top","target":"_self"},{"class":"et_pb_sidebar_0_tb_footer","url":"https:\/\/csmediatexas.com\/","target":"_blank"},{"class":"et_pb_text_1_tb_footer","url":"https:\/\/princetonherald.com\/","target":"_self"},{"class":"et_pb_text_2_tb_footer","url":"https:\/\/princetonherald.com\/","target":"_self"}];
			</script>
	<style>.wp-container-1 .alignleft { float: left; margin-right: 2em; }.wp-container-1 .alignright { float: right; margin-left: 2em; }</style>
<style>.wp-container-2 .alignleft { float: left; margin-right: 2em; }.wp-container-2 .alignright { float: right; margin-left: 2em; }</style>
<style>.wp-container-3 .alignleft { float: left; margin-right: 2em; }.wp-container-3 .alignright { float: right; margin-left: 2em; }</style>
<style>.wp-container-4 .alignleft { float: left; margin-right: 2em; }.wp-container-4 .alignright { float: right; margin-left: 2em; }</style>
<style>.wp-container-5 .alignleft { float: left; margin-right: 2em; }.wp-container-5 .alignright { float: right; margin-left: 2em; }</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://princetonherald.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://princetonherald.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9.5' type='text/css' media='all' />
<script type='text/javascript' src='https://princetonherald.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://princetonherald.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='jquery-js-after'>
jqueryParams.length&&$.each(jqueryParams,function(e,r){if("function"==typeof r){var n=String(r);n.replace("$","jQuery");var a=new Function("return "+n)();$(document).ready(a)}});
</script>
<script type='text/javascript' id='divi-custom-script-js-extra'>
/* <![CDATA[ */
var DIVI = {"item_count":"%d Item","items_count":"%d Items"};
var et_builder_utils_params = {"condition":{"diviTheme":true,"extraTheme":false},"scrollLocations":["app","top"],"builderScrollLocations":{"desktop":"app","tablet":"app","phone":"app"},"onloadScrollLocation":"app","builderType":"fe"};
var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_custom = {"ajaxurl":"https:\/\/princetonherald.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/princetonherald.com\/wp-content\/themes\/Divi\/images","builder_images_uri":"https:\/\/princetonherald.com\/wp-content\/themes\/Divi\/includes\/builder\/images","et_frontend_nonce":"74ca7131e0","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"f7b4b231dc","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","wrong_checkbox":"Checkbox","ignore_waypoints":"no","is_divi_theme_used":"1","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"15001","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://princetonherald.com/wp-content/themes/Divi/js/scripts.min.js?ver=4.14.2' id='divi-custom-script-js'></script>
<script type='text/javascript' src='https://princetonherald.com/wp-content/themes/Divi/includes/builder/feature/dynamic-assets/assets/js/jquery.fitvids.js?ver=4.14.2' id='fitvids-js'></script>
<script type='text/javascript' src='https://princetonherald.com/wp-content/themes/Divi/includes/builder/feature/dynamic-assets/assets/js/easypiechart.js?ver=4.14.2' id='easypiechart-js'></script>
<script type='text/javascript' src='https://princetonherald.com/wp-content/themes/Divi/includes/builder/feature/dynamic-assets/assets/js/salvattore.js?ver=4.14.2' id='salvattore-js'></script>
<script type='text/javascript' src='https://princetonherald.com/wp-content/themes/Divi/core/admin/js/common.js?ver=4.14.2' id='et-core-common-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://princetonherald.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://princetonherald.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.9.5' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://princetonherald.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.9.5' id='wp-mediaelement-js'></script>
<style id="et-builder-module-design-tb-13279-tb-13286-tb-13280-15001-cached-inline-styles">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</style>	
	</body>
</html>

<!--Generated by Endurance Page Cache-->